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Chapter 1

Getting Started With GeoGebra

In this chapter

• Install and start up GeoGebra
• Examine basic features
• Open and save a GeoGebra file

Starting up GeoGebra

GeoGebra can be downloaded for free at http://www.geogebra.org

It can also be accessed through any browser through the above web site (you still click on the “Down-
load” button, and look for the web applet option). This is useful if you are using a public computer or a 
computer in a lecture hall and do not have download and install permissions.

This chapter will familiarize you with various basic features of GeoGebra (pronunced Gee-O-gebra). 
We will introduce features of GeoGebra as the need arises. When working with the examples given, 
you should be at a computer with the Geogebra program open.

Start up the GeoGebra software. The main buttons are shown below and each button has a drop down 
menu associated with it..

Algebra View Geometry View
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Do not be concerned if your screen does not exactly look like the above. When we work our examples, 
you will be shown which tools must be used and how you can access them via the toolbar.

GeoGebra is a software with a wide variety of capabilities.This guide will focus primarily on how to 
work with functions and their properties using GeoGebra. 

Graphing a function 

The easiest way to see what GeoGebra is about is by graphing a function. Unlike most graphing soft-
ware, GeoGebra allows you to dynamically change the graph with the mouse. That’s what sets it 
apart.

Example 1 Graph the function  

Solution

1 In input bar, type f(x)=3x^2+1 
2 Press <Enter> and you’ll see the graph.

Moving the graph
GeoGebra is a dynamic geometry software. That is,  the graph that’s drawn is not static. It has various 
properties which can be examined individually. A simple property is to just move the graph. To do this, 
follow these steps.

1 Click on the  selection tool.  . This enables the drag option.

2 Point to the graph, then hold down the left mouse button,  and move the graph with the mouse.
3 As you move the graph, note how the expression for f(x) changes.

f x  3x2 1+=
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Changing line styles
To change the line color and/or styles in a plot, right  click into the curve you want to change. Click on 
Properties, and set the options you wish.

Points  on the graph

Example 2 Use the graph of  to find various points on the curve and trace along the 

curve.

Solution

Steps to trace a point along a graph

1 Click on the point tool and choose new point. 

2 Now  click on the selection tool. 

3 Move mouse until you see the graph highlighted. Left click to place a point on the graph. Move 
mouse to the point A on the graph, hold down left mouse button and start moving your mouse. You 
should see the point A tracing along the curve. Your window should be similar to the following.

f x  3x2 1+=
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Scaling the axes

You can change the scale on the axes by simply clicking on the drawing pad tool . Point the 

mouse to the axis you want to scale. By holding down your mouse button you can stretch or shrink the 
x or y axes.

You can also use the drop down menu from the drwaing pad tool to zoom in or zoom out.

Saving GeoGebra files
1 Open the File menu and select Save.
2  Select a folder where you want to store the file, or create a new folder.
3   Type in a name for your GeoGebra file.
4   Click Save in order to finish this process. A file with the extension ‘.ggb’ is created. This exten-

sion identifies GeoGebra files and indicates that they can only be opened with GeoGebra.

Avoid using spaces or special symbols in a file name since they can cause unnecessary problems when 
transferred to other computers. Instead you can use underscores or upper case letters within the file 
name (e.g. First_Drawing.ggb).

Note that the coordinates of the point A are displayed under Dependent Objects. That’s because 
the point A depends on the function f.
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Printing and exporting graphs
Once you’ve drawn a graph with GeoGebra, you may want to export the graph so that you can use it 
later for another purpose.

To do this, click on File > Export >Graphics View.... Select the option you prefer. You can save as a 
graphics file (you will be prompted on the file tye - png, pdf etc.) or save in the Clipboard to paste in a 
document..

Some Common Errors

• To move the graph around, you need to have the selection tool highlighted.
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Chapter 2

Lines and Linear Equations

In this chapter 

• Graph a line and find its equation given two points
• Explore the slope triangle
• Find distance between two points 
• Parallel and perpendicular lines
• Creating dynamoc graphs with sliders

Graphing a line  given two points

A simple way to explore the powerful features of GeoGebra is to plot two points, and draw a line. 
GeoGebra will automatically determine its equation

Example 1  Plot the  points (2,3) and (-4,1) and draw a line through them.  

Solution 
1 Click on Options > Drawing Pad.
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2 Use the options here to set up your drawing grid.

3 In the Input box, type A=(2,3). Press <ENTER>. Then type B=(-4,1). The two points will be 
plotted as follows.
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4 Now choose the line tool . Click on Point A. A line will appear. Guide the line to Point B 

and click. You should see a graph similar to the one below 

5 Save the file as line1.ggb. We will use it later in this chapter.

Check it out

• Click on the selection tool and move the graph. You can translate the graph. See what happens 
to the points A and B and the equation.

• You can also rotate the line around a point. The drop down menu from the selection tool has an 
option for this.

Using the slope triangle

Using GeoGebra, you can visually indicate the slope of the line that you graphed in Example 1. Fur-
thermore, you can see how the slope changes as you move one or both of the points.
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Example 2  Use GeoGebra to indicate the slope of the line in Example 1.  

Solution

1 Open the file line1.ggb, created in Example 1. If you were moving the line around, the points 
A and B may have changed in the file. If so, in the algebra window, double click on B to (-4,1). 
You can now edit the coordinates of Point B. You can also do this for Point A(2,3).

2 Click at the bottom right of  the angle button , and choose the slope button. 

3 Move your mouse to highlight the line and click. The slope triangle and the value of the slope will 
appear on the graph. and in the algebra window.

4 You can also find the slope by typing  m=Slope[a] in the Input box. Here, a is the name of the 
line that was created and m is the letter assigned to the slope.

5 You can display the equation of Line a in slope-intercept form by right clicking on its equation and 
selecting Equation y=mx+b 

6 Save this file under the original name or to a different name.

Check it out

• Click on the selection tool, and move Point B.  Keep Point A fixed. What do you notice about 
the slope? 

• Calculates  values of the slope for some different values of Point B and compare to the value 
given in GeoGebra.

• In the algebra window, double click on B. You can now edit the coordinates of Point B. You 
can also do this for Point A.
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Finding distance between two points

You can use the Distance command in the Input box to calculate the distance between two points.

Example 2  Use GeoGebra to find the distance between A(-4,1) and B(3,-2). 

Solution

1 Start up GeoGebra or open a new GeoGebra workspace by choosing File> New.
2 In the Input box, type A=(-4,1). Press <ENTER> and then type B=(3,-2).
3 In the Input box, type d=Distance[A,B]. Press <ENTER>.The value of the distance is dis-

played in the algebra window.

Check it out

• Use the distance formula   to verify that the distance given by 

GeoGebra is correct.
• Find the midpoint of points A and B by typing C=Midpoint[A,B] in the Input box
• A good use of the distance function is to help you find the perimeter of a polygon whose verti-

ces are given by coordinates. Plot the points (1,2), (3,-1) and (-1,-2) in GeoGebra. Connect 
each pair of points with a line segment by clicking on the Line tool and choosing the segment 
option.. Find the perimeter of the resulting triangle.

Parallel and perpendicular lines

Using GeoGebra, you can examine both the geometric and algebraic  relationships between two paral-
lel or two perpendicular lines.

d x2 x1– 2
y2 y1– 2

+=
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Example 4   Use Geogebra to sketch the line parallel to the line    and passing through 
(-1,2).

Solution 

1 Start up GeoGebra or open a new GeoGebra workspace by choosing File> New.  To see the grid, 
make sure the menu item View > Grid is checked.

2 In the Input box, type y=-2x+3. Press <ENTER>. Youll see a line with label a. The name of the 
line is a. You can refer to this particular line as a in later commands in the Input box. 

3 Now type P=(-1,2) in the Input box. Press <ENTER>. Click on the button with perpendicular 
lines and then click on the small red arrow.  From the submenu, choose Parallel Line.

y 2x– 3+=
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4 Now select the Point P and the line a. The parallel line passing through P is now drawn and its 
equation is given. 

5 Use GeoGebra to find the slope of each line. Type Slope[a] in the Input box. Press 
<ENTER>. Then type Slope[b] in the Input box. Press <ENTER>. The slopes and the slope 
triangles  are now given. Check these values by hand. 

Check it out

• What do you observe about the slopes of parallel lines?
• Find the equation of the parallel line by hand, and check with the one from GeoGebra.. 
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Example 5   Use Geogebra to sketch the line perpendicular to the line    and passing 
through (-1,2).

Solution 

1 Start up GeoGebra or open a new GeoGebra workspace by choosing File> New.  To see the grid, 
make sure the menu item View > Grid is checked. 

2 To get a square grid, right-click in the graphing area. Select Properties and set xaxis:yaxis ratio to 
1:1.  Otherwise, perpendicular lines will not appear perpendicular!

3 In the Input box, type y=-2x+3. Press <ENTER>. Youll see a line with label a. The name of the 
line is a. You can refer to this particular line as a in later commands in the Input box. 

4 Now type P=(-1,2) in the Input box. Press <ENTER>. Click on the button with perpendicular 
lines . 

y 2x– 3+=
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5 Now select the Point P and the line a. The perpendicular line  b, passing through P, is now drawn 
and its equation is given. 

6 Use GeoGebra to find the slope of each line. Type m1=Slope[a] in the Input box. Press 
<ENTER>. Then type m2=Slope[b] in the Input box. Press <ENTER>. The slopes and the 
slope triangles  are now given. Check these values by hand by examining the slope-intercept forms 
of the equations.  

Check it out

• Do you observe about the slopes of perpendicular lines are negative reciprocals of each other?
• Find the equation of the perpendicular line by hand, and check with the one from GeoGebra.
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Creating dynamic graphs with sliders

In GeoGebra, you can introduce sliders to make your graph change when its parameters change. For 
example, the equation of a line is given  by  . You can set the slope, m, and the y-intercept, b, 
as parameters and then define the line. This allows GeoGebra to change m and b dynamically.

Example 6   Use Geogebra to sketch the line    , with m = 3 and b= 4. USe a slider to 
vary m and b.

Solution

1 Start up GeoGebra or open a new GeoGebra workspace by choosing File> New.  To see the grid, 
make sure the menu item View > Grid is checked. 

2 In the Input box, type m=3. Press <ENTER>. Then type b=4. Press <ENTER>.
3 Now type y=m*x+b in the Input box.

4 If you look at the left panel, you will see that the line is dependent on the “objects” m and b. Click 
on the b = 4 button in the left panel. You will see a slider appear in the graphing area. Do the same 

y mx b+=

y mx b+=
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for the m = 3 button. Your graph should resemble the following. Now move each slider with your 
mouse and see what happens to the graph.

Check it out

• As m varies from negative to zero to positive, what do you observe about the slant of the line?
• What do you observe about the line as b varies from  negative to zero to positive?
• You can add a slope triangle to visualize the slope of the line. Refer to Example 2 for instruc-

tions.
• The default range for the sliders is from -5 to 5. You can change this by right-clicking  on the 

slider and then modifying the range under the slider tab in the properties dialog box.  You can 
also change its color and other properties. Try it!

NOTE: This guide is a work in progress. Chapters on different functions, including trig func-
tions, and conic section will be added. Your comments are welcome. Please email comments to 

reva@mymathspace.net

(Notes on new features to include:

http://www.geogebra.org/talks/2009/GeoGebra_WS9_Spreadsheet_Statistics.pdf

Idea: mx+b : parametrize m and b; list view of points and “guess” at line of best fit)


